DTMF tones not working on Mac Bria 5.0.3 build 88307

Andreas Yankopolus shared this problem 2 months ago
Solved

I'm unable to get DTMF tones sent to the callee with the current version of Bria on MacOS 10.13.1. After the callee picks up, I can hear Bria making DTMF tones, but the callee doesn't hear them. This occurs whether I include the tones in the dial string or type them manually after the call is established. I'm only making a single call, and I'm seeing the call info outlined in yellow on the Bria window.

An example dial string would be:

+1-234-567-8901,,,123456#;

I can hear Bria make the call, the callee picks up and requests the access code, I hear Bria dial the access code, then the callee asks for the access code again because the tones weren't actually sent to the callee. I can then try typing the access code on the keyboard. Again, I hear the tones, but the callee doesn't.

Edit: I'm having to make these calls using Bria on my iPhone, where DTMF tones work as they should.

Comments (8)

photo
1

Hello Andreas,

Can you please make sure you're entering the digits in the correct place? Please see the picture attached, red arrow.

Cheers,

Harpreet Singh

Files: dtmf.JPG
photo
1

Will try that manually. But perhaps more importantly, what about the dial string not working?

photo
photo
1

Oh sorry, so you're trying to dial the whole string together at the first place. I think I misunderstood. I believe you're using the "," for pauses. In desktop Bria, rather than , you need to use P. Please check the link below and try again:

https://support.counterpath.com/topic/how_do_i_add_a_pause_in_a_dialed_number_so_i_can_access_an_extension

- Harpreet

photo
1

Thanks for the quick reply. I've been trying both methods but am particularly interested in dialing the whole string. The referenced link mentions:

"Type a capital P or X or a comma to denote a 1 second pause and then the extension"

Hence my use of a comma. I'll try using P when making calls in the morning and update this thread.

photo
photo
2

You can also try changing the DTMF type in Bria. Go to Bria's Preferences -> Calls -> DTMF. Try a call for every option.

photo
1

Have not tried this. Thanks! Will do so and respond…

photo
1

Popped open this setting and found it set to "Send via SIP INFO". Changing it to "Send in-band" appears to solve the problem. Thanks again for your help!

photo
photo
2

Sounds good, Andreas. I will go ahead and close this ticket now. For any other issue please create a new ticket.

- Harpreet