RTCP Line in the initial SDP

Alexander Haugg shared this question 1 month ago
Answered

Hi,

I need the RTCP Media Attribute in the initial SDP if I initiate an outbound call with the Bria 4 Client. Is there a hidden setting to enable this?

In the configuration possibilities i don't found this.

I am using the Bria 4 Client - Version 4.8.1 - Build 84929

Comments (12)

photo
1

Hi Alexander,

We do support RTCP for Bria and there isn't any specific setting to enable it. It hsould be implemented automatically. Is there any issue with it?

Cheers,

Harpreet Singh

photo
1

The Bria 4 send RTCP, that's OK, but in the SDP from the Bria Client the RTCP line in the media section is not exists.

This RTCP line is needed that the receiver now that RTCP is required.

See the bold line in the second SDP example!

SDP media section from Bria 4 Client:

m=audio 56590 RTP/AVP 9 8 120 0 101

a=rtpmap:120 opus/48000/2

a=fmtp:120 useinbandfec=1; usedtx=1; maxaveragebitrate=64000

a=rtpmap:101 telephone-event/8000

a=fmtp:101 0-15

a=sendrecv

SDP media section from the SIP PBX:

m=audio 31206 RTP/AVP 8 101

a=rtpmap:8 PCMA/8000

a=rtpmap:101 telephone-event/8000

a=fmtp:101 0-16

a=ptime:20

a=rtcp:31207 IN IP4 12.32.4.21

photo
1

Please follow thee steps below and send me a log. I need to further check with engineering to see what is required by Bria to send RTCP.

In Bria 4, select help -> troubleshooting -> support. Once there, please set the log level to debug by dragging the slider to the right. Now fully close Bria and open again. Next, please replicate the problem you have been experiencing.

After replicating the problem, please click send log and then add any additional information you would like to send in the box which pops up (or nothing if you so desire) and click send log once again. A reference number will be generated for the log you submitted. Please post the reference here so I can find your log.

- Harpreet

photo
1

See in the OutputLog.txt in line 1302 - 1307 the SDP audio section, there is no RTCP line.

For a good Example see the RTCP line in the SDP from the 200 OK in the line 1401

photo
1

The RTCP line in the SDP header is needed that the receiver is triggered to send RTCP

photo
1

From the initial discussion with engineering, Bria would likely include rtcp attribute only if a STUN server is set (either through SRV or manually specified). Do you have a stun server to connect with Bria? In the meantime, I am gathering more information with the engineering on it.

- Harpreet

photo
1

I have a stun server configured and the stun Binding Request will be answered with Binding Success Response, but the rtcp attribute is missing too.

photo
1

Can you also set the Network Traversal method to Auto-Detect and then try again? Go to Account settings -> sip account -> topology.

- Harpreet

photo
1

OK, that's works.

At first is it OK for me.

photo
1

I'm sorry, did you ask me if the settings are OK for you or are you telling me that they are OK for you?

photo
1

No Problem.

I tell you, this solution is OK for me.